Minor outage
Incident Report for Hello Retail
Resolved
This incident has been resolved.
Posted about 1 year ago. May 21, 2018 - 15:55 CEST
Monitoring
The issue has been identified and resolved, we are monitoring the service closely
Posted about 1 year ago. May 21, 2018 - 11:37 CEST