Performance issues
Incident Report for Hello Retail
Resolved
The issue has now been resolved
Posted Nov 11, 2019 - 16:32 CET
Identified
We are currently experiencing issues with parts of our system. We have identified the issue and we are working to resolve it now. We will post and update as soon as we know more.

We are very sorry for the inconvenience this causes.
Posted Nov 11, 2019 - 16:26 CET
This incident affected: Admin dashboard, Script, Product recommendations, Newsletter content, Search, and Wish list widget.